Microsoft

Microsoft Intune Feedback

Suggestion box powered by UserVoice

How can we improve Microsoft Intune

Intune/Autopilot Windows Updates

When deploying a device with Autopilot, they come shipped with older versions of Windows (1703). Some policies are only compatible with later versions of Windows. It would be great if Intune/Autopilot could initiate that OS update as part of the deployment.

65 votes
Vote
Sign in
(thinking…)
Sign in with: sso facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Ian Wright shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

8 comments

Sign in
(thinking…)
Sign in with: sso facebook google
Signed in as (Sign out)
Submitting...
  • DoudiCH commented  ·   ·  Flag as inappropriate

    This will really help in deployments and would solve so many issues with configurations, not present in older versions but needed on our customers site.

  • Matias Hohl commented  ·   ·  Flag as inappropriate

    This is really critical for us as we want to use hybrid join and this is only supported with 1809 or newer.

  • Thomas commented  ·   ·  Flag as inappropriate

    We need to set a required base version of the Windows OS to start AutoPilot with. So if the desired OS level is not installed, the necessary updates have to be installed and only then the AutoPilot process kicks off.

  • Patrick Morandi commented  ·   ·  Flag as inappropriate

    This is a very important feature because we can't ensure which version the hardware vendor ships with. It would be best if we could specify in the autopilot configuration which version the client has to update to before the autopilot phase starts.

  • Kevin Kaminski commented  ·   ·  Flag as inappropriate

    This problem is becoming more critical as bugs with autopilot enrollment require a newer version of Windows for resolution. Right now people have to re-image their machine with a newer version of Windows to fix enrollment problems.

  • Ben Hos commented  ·   ·  Flag as inappropriate

    This, I currently wish to use 1809 features and as of this comment Lenovo are currently only shipping devices with 1803.

Feedback and Knowledge Base